ChevelleForum.net

Go Back   Chevrolet Chevelle Forums > Chevrolet Chevelle Garage > Electrical

Reply
 
Thread Tools Display Modes
  #1  
Old 01-31-2017, 08:25 AM
sschevellenl sschevellenl is offline
Junior Member
 
Join Date: Aug 2016
Posts: 2
Default Rev engine to get alternator to start charging ?

Hey guys , just put a set of autometer mechancial gauges in my 70 ss. As of now i have to rev the engine to get it to start to charge. as you as your start it, you have to stab the gas a few times, then it will charge all day long, if you dont do this, it will chug along the highway and not charge. Any ideas of what the problem is ? Help much appreciated.
Reply With Quote
  #2  
Old 01-31-2017, 03:18 PM
chevymaher's Avatar
chevymaher chevymaher is offline
Senior Member
 
Join Date: Mar 2014
Location: Kentucky
Posts: 1,152
Default

Sounds like the voltage regulator isn't exciting the alt field until the revs go up. I would say voltage reg is getting weak.
Reply With Quote
  #3  
Old 01-31-2017, 09:42 PM
shadowgray396's Avatar
shadowgray396 shadowgray396 is offline
Senior Member
 
Join Date: Dec 2009
Location: Tigard, Oregon
Posts: 5,969
Default

I would agree
__________________
Ray
1970 SS Chevelle Van Nuys Built
Reply With Quote
  #4  
Old 04-10-2017, 07:51 AM
pitts64's Avatar
pitts64 pitts64 is offline
Member
 
Join Date: Mar 2017
Location: Pittsburgh, Pa.
Posts: 32
Default

I had the same issues. I changed the regulator, nothing, then took that rebuilt alt to the alternator/starter repair shop and all issues went away... The alternator even looked much better..
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:48 PM.



Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Audiokarma.org